Heap-based Buffer Overflow Affecting ghostscript package, versions <10.08.0~dfsg-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.24% (15th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-GHOSTSCRIPT-22083445
  • published31 Oct 2026
  • disclosed30 Oct 2026

Introduced: 30 Oct 2026

NewCVE-2026-110133  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade Debian:unstable ghostscript to version 10.08.0~dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ghostscript package and not the ghostscript package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

A flaw was found in Ghostscript. When processing a specially crafted TrueType font or document embedding one, an accounting error during font rendering can bypass buffer size checks, triggering a heap-based buffer overflow. A remote attacker could exploit this by enticing a victim or automated service to open the malicious content, potentially resulting in a Denial of Service (DoS) crash or arbitrary code execution.

CVSS Base Scores

version 3.1