Memory Leak Affecting gss-ntlmssp package, versions <1.2.0-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.1% (62nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-GSSNTLMSSP-3319419
  • published14 Feb 2023
  • disclosed14 Feb 2023

Introduced: 14 Feb 2023

CVE-2023-25566  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Debian:unstable gss-ntlmssp to version 1.2.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gss-ntlmssp package and not the gss-ntlmssp package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

GSS-NTLMSSP is a mechglue plugin for the GSSAPI library that implements NTLM authentication. Prior to version 1.2.0, a memory leak can be triggered when parsing usernames which can trigger a denial-of-service. The domain portion of a username may be overridden causing an allocated memory area the size of the domain name to be leaked. An attacker can leak memory via the main gss_accept_sec_context entry point, potentially causing a denial-of-service. This issue is fixed in version 1.2.0.

CVSS Base Scores

version 3.1