Incorrect Default Permissions Affecting gvfs package, versions <1.38.1-5


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.39% (33rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-GVFS-449831
  • published11 Jun 2019
  • disclosed11 Jun 2019

Introduced: 11 Jun 2019

CVE-2019-12795  (opens in a new tab)
CWE-276  (opens in a new tab)

How to fix?

Upgrade Debian:unstable gvfs to version 1.38.1-5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gvfs package and not the gvfs package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

daemon/gvfsdaemon.c in gvfsd from GNOME gvfs before 1.38.3, 1.40.x before 1.40.2, and 1.41.x before 1.41.3 opened a private D-Bus server socket without configuring an authorization rule. A local attacker could connect to this server socket and issue D-Bus method calls. (Note that the server socket only accepts a single connection, so the attacker would have to discover the server and connect to the socket before its owner does.)

CVSS Base Scores

version 3.1