Missing Authorization Affecting incus package, versions <7.0.1-5


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.21% (11th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-INCUS-21479342
  • published23 Oct 2026
  • disclosed22 Oct 2026

Introduced: 22 Oct 2026

NewCVE-2026-115373  (opens in a new tab)
CWE-862  (opens in a new tab)

How to fix?

Upgrade Debian:unstable incus to version 7.0.1-5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream incus package and not the incus package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Incus before 6.0.7, 6.1.0 before 7.0.2, and 7.1.0 before 7.5.0 contains a missing authorization vulnerability in GET /1.0/operations/{uuid} that lets project-restricted clients read operations in other projects. Attackers holding a restricted certificate and a known operation UUID can retrieve command lines, environment secrets, websocket secrets, and trust enrolment tokens.

CVSS Base Scores

version 3.1