Insufficiently Protected Credentials Affecting incus package, versions <7.0.1-5


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.22% (12th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-INCUS-21479360
  • published23 Oct 2026
  • disclosed22 Oct 2026

Introduced: 22 Oct 2026

NewCVE-2026-115371  (opens in a new tab)
CWE-522  (opens in a new tab)

How to fix?

Upgrade Debian:unstable incus to version 7.0.1-5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream incus package and not the incus package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Incus 6.0.3 before 6.0.7, 6.6.0 before 7.0.2, and 7.1.0 before 7.5.0 contains an improper authorization vulnerability that allows restricted TLS clients to read storage bucket keys in the default project. Attackers can query the bucket keys endpoints to obtain S3 access and secret keys, then read, modify or delete objects in those buckets.

CVSS Base Scores

version 3.1