Authentication Bypass Affecting kronosnet package, versions <1.35-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.26% (17th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-KRONOSNET-18300186
  • published25 Jul 2026
  • disclosed21 Jul 2026

Introduced: 21 Jul 2026

CVE-2026-15812  (opens in a new tab)
CWE-290  (opens in a new tab)

How to fix?

Upgrade Debian:unstable kronosnet to version 1.35-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kronosnet package and not the kronosnet package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

A vulnerability was found in the internal Access Control List (ACL) subsystem of kronosnet (Version affected: <= 1.34). When the framework is explicitly configured to manage dynamic links (accepting network traffic from any IP address) without network payload encryption, the validation architecture implicitly trusts the link ID provided within incoming data packets. A remote, unauthenticated attacker can exploit this lack of validation by spoofing a legitimate link ID inside crafted network frames. This allows the attacker to fully bypass the ACL framework and inject arbitrary data packets into the application layer, potentially leading to data corruption or service instabilities.

CVSS Base Scores

version 3.1