Uncontrolled Search Path Element Affecting ktexteditor package, versions <5.93.0-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.89% (56th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-KTEXTEDITOR-2396498
  • published10 Feb 2022
  • disclosed11 Feb 2022

Introduced: 10 Feb 2022

CVE-2022-23853  (opens in a new tab)
CWE-427  (opens in a new tab)

How to fix?

Upgrade Debian:unstable ktexteditor to version 5.93.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ktexteditor package and not the ktexteditor package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

The LSP (Language Server Protocol) plugin in KDE Kate before 21.12.2 and KTextEditor before 5.91.0 tries to execute the associated LSP server binary when opening a file of a given type. If this binary is absent from the PATH, it will try running the LSP server binary in the directory of the file that was just opened (due to a misunderstanding of the QProcess API, that was never intended). This can be an untrusted directory.

CVSS Base Scores

version 3.1