Link Following Affecting kwallet-pam package, versions <5.12.1-2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.44% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-KWALLETPAM-267576
  • published8 May 2018
  • disclosed8 May 2018

Introduced: 8 May 2018

CVE-2018-10380  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade Debian:unstable kwallet-pam to version 5.12.1-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kwallet-pam package and not the kwallet-pam package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

kwallet-pam in KDE KWallet before 5.12.6 allows local users to obtain ownership of arbitrary files via a symlink attack.