Out-of-bounds Read Affecting ldns package, versions <1.8.1-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.22% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-LDNS-2359225
  • published24 Jan 2022
  • disclosed21 Jan 2022

Introduced: 21 Jan 2022

CVE-2020-19860  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Debian:unstable ldns to version 1.8.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ldns package and not the ldns package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

When ldns version 1.7.1 verifies a zone file, the ldns_rr_new_frm_str_internal function has a heap out of bounds read vulnerability. An attacker can leak information on the heap by constructing a zone file payload.

CVSS Base Scores

version 3.1