Out-of-Bounds Affecting libgsf package, versions <1.14.2-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.43% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-LIBGSF-296368
  • published30 Nov 2006
  • disclosed30 Nov 2006

Introduced: 30 Nov 2006

CVE-2006-4514  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:unstable libgsf to version 1.14.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgsf package and not the libgsf package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Heap-based buffer overflow in the ole_info_read_metabat function in Gnome Structured File library (libgsf) 1.14.0, and other versions before 1.14.2, allows context-dependent attackers to execute arbitrary code via a large num_metabat value in an OLE document, which causes the ole_init_info function to allocate insufficient memory.

CVSS Base Scores

version 3.1