Improper Input Validation Affecting libhibernate-validator-java Open this link in a new tab package, versions *


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DEBIANUNSTABLE-LIBHIBERNATEVALIDATORJAVA-573074

  • published

    23 Jun 2020

  • disclosed

    6 May 2020

How to fix?

There is no fixed version for Debian:unstable libhibernate-validator-java.

NVD Description

Note: Versions mentioned in the description apply to the upstream libhibernate-validator-java package.

A flaw was found in Hibernate Validator version 6.1.2.Final. A bug in the message interpolation processor enables invalid EL expressions to be evaluated as if they were valid. This flaw allows attackers to bypass input sanitation (escaping, stripping) controls that developers may have put in place when handling user-controlled data in error messages.