Resource Management Errors Affecting libkdcraw package, versions <24.12.0-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.5% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-LIBKDCRAW-8537310
  • published20 Dec 2024
  • disclosed14 Aug 2013

Introduced: 14 Aug 2013

CVE-2013-2126  (opens in a new tab)
CWE-399  (opens in a new tab)

How to fix?

Upgrade Debian:unstable libkdcraw to version 24.12.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libkdcraw package and not the libkdcraw package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Multiple double free vulnerabilities in the LibRaw::unpack function in libraw_cxx.cpp in LibRaw before 0.15.2 allow context-dependent attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a malformed full-color (1) Foveon or (2) sRAW image file.

CVSS Base Scores

version 3.1