Improper Privilege Management Affecting lightdm package, versions <0.9.6-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.36% (28th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-LIGHTDM-368031
  • published27 Jun 2018
  • disclosed19 Nov 2019

Introduced: 27 Jun 2018

CVE-2011-3349  (opens in a new tab)
CWE-269  (opens in a new tab)

How to fix?

Upgrade Debian:unstable lightdm to version 0.9.6-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lightdm package and not the lightdm package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

lightdm before 0.9.6 writes in .dmrc and Xauthority files using root permissions while the files are in user controlled folders. A local user can overwrite root-owned files via a symlink, which can allow possible privilege escalation.

CVSS Base Scores

version 3.1