Deserialization of Untrusted Data Affecting logback package, versions <1:1.2.8-1


0.0
medium

Snyk CVSS

    Attack Complexity High
    Privileges Required High
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 1.56% (87th percentile)
Expand this section
NVD
6.6 medium
Expand this section
Red Hat
6.6 medium
Expand this section
SUSE
6.6 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIANUNSTABLE-LOGBACK-2321376
  • published 17 Dec 2021
  • disclosed 16 Dec 2021

How to fix?

Upgrade Debian:unstable logback to version 1:1.2.8-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream logback package and not the logback package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

In logback version 1.2.7 and prior versions, an attacker with the required privileges to edit configurations files could craft a malicious configuration allowing to execute arbitrary code loaded from LDAP servers.