Out-of-bounds Read Affecting miniupnpd package, versions <2.3.10-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.67% (52nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-MINIUPNPD-16104323
  • published18 Apr 2026
  • disclosed17 Apr 2026

Introduced: 17 Apr 2026

CVE-2026-5720  (opens in a new tab)
CWE-125  (opens in a new tab)
CWE-191  (opens in a new tab)

How to fix?

Upgrade Debian:unstable miniupnpd to version 2.3.10-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream miniupnpd package and not the miniupnpd package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

miniupnpd contains an integer underflow vulnerability in SOAPAction header parsing that allows remote attackers to cause a denial of service or information disclosure by sending a malformed SOAPAction header with a single quote. Attackers can trigger an out-of-bounds memory read by exploiting improper length validation in ParseHttpHeaders(), where the parsed length underflows to a large unsigned value when passed to memchr(), causing the process to scan memory far beyond the allocated HTTP request buffer.

CVSS Base Scores

version 3.1