Use After Free Affecting mruby package, versions <3.0.0-4


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.79% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-MRUBY-2441775
  • published7 Apr 2022
  • disclosed5 Apr 2022

Introduced: 5 Apr 2022

CVE-2022-1212  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Debian:unstable mruby to version 3.0.0-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mruby package and not the mruby package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Use-After-Free in str_escape in mruby/mruby in GitHub repository mruby/mruby prior to 3.2. Possible arbitrary code execution if being exploited.

CVSS Base Scores

version 3.1