Arbitrary Code Injection Affecting neovim package, versions <0.12.3-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.92% (56th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-NEOVIM-17238185
  • published8 Jun 2026
  • disclosed8 Jun 2026

Introduced: 8 Jun 2026

CVE-2026-11487  (opens in a new tab)
CWE-74  (opens in a new tab)
CWE-77  (opens in a new tab)

How to fix?

Upgrade Debian:unstable neovim to version 0.12.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream neovim package and not the neovim package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

A flaw has been found in Neovim up to 0.12.2. Affected by this issue is the function M.read of the file runtime/lua/vim/secure.lua of the component View Branch. Executing a manipulation of the argument path can lead to command injection. It is possible to launch the attack on the local host. The exploit has been published and may be used. This patch is called f83e0dcaf8cf18de94828341b0a1a61a86c75baf. A patch should be applied to remediate this issue.

CVSS Base Scores

version 3.1