Cross-site Scripting (XSS) Affecting node-send package, versions <1.1.0+~cs1.19.4-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.54% (44th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-NODESEND-7931732
  • published12 Sept 2024
  • disclosed10 Sept 2024

Introduced: 10 Sep 2024

CVE-2024-43799  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Debian:unstable node-send to version 1.1.0+~cs1.19.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-send package and not the node-send package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Send is a library for streaming files from the file system as a http response. Send passes untrusted user input to SendStream.redirect() which executes untrusted code. This issue is patched in send 0.19.0.

CVSS Base Scores

version 3.1