Directory Traversal Affecting opam package, versions <2.5.1-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.21% (11th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-OPAM-16093914
  • published17 Apr 2026
  • disclosed16 Apr 2026

Introduced: 16 Apr 2026

CVE-2026-41082  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Debian:unstable opam to version 2.5.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opam package and not the opam package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

In OCaml opam before 2.5.1, a .install field containing a destination filepath can use ../ to reach a parent directory.

CVSS Base Scores

version 3.1