CVE-2019-16729 Affecting pam-python package, versions <1.0.7-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.36% (28th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-PAMPYTHON-468976
  • published24 Sept 2019
  • disclosed24 Sept 2019

Introduced: 24 Sep 2019

CVE-2019-16729  (opens in a new tab)

How to fix?

Upgrade Debian:unstable pam-python to version 1.0.7-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pam-python package and not the pam-python package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

pam-python before 1.0.7-1 has an issue in regard to the default environment variable handling of Python, which could allow for local root escalation in certain PAM setups.

CVSS Base Scores

version 3.1