CVE-2026-50738 Affecting pglogical package, versions <2.4.8-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.51% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-PGLOGICAL-18391846
  • published29 Jul 2026
  • disclosed28 Jul 2026

Introduced: 28 Jul 2026

CVE-2026-50738  (opens in a new tab)

How to fix?

Upgrade Debian:unstable pglogical to version 2.4.8-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pglogical package and not the pglogical package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

A use-after-free condition exists in pglogical's worker signaling code, where a worker structure can be dereferenced after the underlying slot has been freed or recycled during normal worker lifecycle events. The condition is reachable during normal replication operation, including by a low-privileged user able to influence worker start, stop, and restart timing through permitted pglogical operations. In the typical case the condition crashes replication workers, causing an availability impact. In the worst case a use-after-free in a PostgreSQL backend can be leveraged as a remote code execution primitive at the privilege of that backend.

CVSS Base Scores

version 3.1