Protection Mechanism Failure Affecting php-twig package, versions <3.27.0-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.42% (35th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-PHPTWIG-17090562
  • published29 May 2026
  • disclosed14 Jul 2026

Introduced: 29 May 2026

CVE-2026-48806  (opens in a new tab)
CWE-693  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade Debian:unstable php-twig to version 3.27.0-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-twig package and not the php-twig package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Twig is a template language for PHP. Prior to 3.27.0, ArrayExpression does not guard dynamic mapping keys that are coerced to strings, allowing PHP to invoke __toString() on a Stringable object used as a mapping key without calling SandboxExtension::ensureToStringAllowed(). This issue is fixed in version 3.27.0.

CVSS Base Scores

version 3.1