Out-of-bounds Read Affecting pngcheck package, versions <2.3.0-13


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.22% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-PNGCHECK-1048072
  • published3 Dec 2020
  • disclosed8 Dec 2020

Introduced: 3 Dec 2020

CVE-2020-27818  (opens in a new tab)
CWE-125  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade Debian:unstable pngcheck to version 2.3.0-13 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pngcheck package and not the pngcheck package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

A flaw was found in the check_chunk_name() function of pngcheck-2.4.0. An attacker able to pass a malicious file to be processed by pngcheck could cause a temporary denial of service, posing a low risk to application availability.

CVSS Base Scores

version 3.1