CVE-2024-3772 Affecting pydantic package, versions <1.10.13-0.1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.96% (59th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-PYDANTIC-6615662
  • published16 Apr 2024
  • disclosed15 Apr 2024

Introduced: 15 Apr 2024

CVE-2024-3772  (opens in a new tab)

How to fix?

Upgrade Debian:unstable pydantic to version 1.10.13-0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pydantic package and not the pydantic package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Regular expression denial of service in Pydanic < 2.4.0, < 1.10.13 allows remote attackers to cause denial of service via a crafted email string.

CVSS Base Scores

version 3.1