CVE-2023-49081 Affecting python-aiohttp package, versions <3.9.1-1


0.0
medium

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.05% (17th percentile)
Expand this section
NVD
5.3 medium
Expand this section
Red Hat
5.8 medium
Expand this section
SUSE
4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIANUNSTABLE-PYTHONAIOHTTP-6096082
  • published 1 Dec 2023
  • disclosed 30 Nov 2023

How to fix?

Upgrade Debian:unstable python-aiohttp to version 3.9.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-aiohttp package and not the python-aiohttp package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. Improper validation made it possible for an attacker to modify the HTTP request (e.g. to insert a new header) or create a new HTTP request if the attacker controls the HTTP version. The vulnerability only occurs if the attacker can control the HTTP version of the request. This issue has been patched in version 3.9.0.