Arbitrary Command Injection Affecting pytorch package, versions <1.13.1+dfsg-1


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIANUNSTABLE-PYTORCH-3149885
  • published 27 Nov 2022
  • disclosed 26 Nov 2022

How to fix?

Upgrade Debian:unstable pytorch to version 1.13.1+dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pytorch package and not the pytorch package as distributed by Debian:unstable. See How to fix? for Debian:unstable relevant fixed versions and status.

In PyTorch before trunk/89695, torch.jit.annotations.parse_type_line can cause arbitrary code execution because eval is used unsafely.

References