CVE-2024-57823 Affecting raptor2 package, versions <2.0.16-6


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.35% (29th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-RAPTOR2-8619947
  • published12 Jan 2025
  • disclosed10 Jan 2025

Introduced: 10 Jan 2025

CVE-2024-57823  (opens in a new tab)

How to fix?

Upgrade Debian:unstable raptor2 to version 2.0.16-6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream raptor2 package and not the raptor2 package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

In Raptor RDF Syntax Library through 2.0.16, there is an integer underflow when normalizing a URI with the turtle parser in raptor_uri_normalize_path().

CVSS Base Scores

version 3.1