Unsigned to Signed Conversion Error Affecting rauc package, versions <1.15.2-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.15% (4th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-RAUC-15909758
  • published5 Apr 2026
  • disclosed31 Mar 2026

Introduced: 31 Mar 2026

CVE-2026-34155  (opens in a new tab)
CWE-196  (opens in a new tab)
CWE-347  (opens in a new tab)

How to fix?

Upgrade Debian:unstable rauc to version 1.15.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rauc package and not the rauc package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

RAUC controls the update process on embedded Linux systems. Prior to version 1.15.2, RAUC bundles using the 'plain' format exceeding a payload size of 2 GiB cause an integer overflow which results in a signature which covers only the first few bytes of the payload. Given such a bundle with a legitimate signature, an attacker can modify the part of the payload which is not covered by the signature. This issue has been patched in version 1.15.2.

CVSS Base Scores

version 3.1