Origin Validation Error Affecting rclone package, versions <1.75.2-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.12% (2nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-RCLONE-21709415
  • published26 Oct 2026
  • disclosed25 Oct 2026

Introduced: 25 Oct 2026

NewCVE-2026-116194  (opens in a new tab)
CWE-346  (opens in a new tab)

How to fix?

Upgrade Debian:unstable rclone to version 1.75.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rclone package and not the rclone package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Rclone from 1.52.0 before 1.75.2 contains a cross-site request forgery vulnerability in the pCloud backend's localhost OAuth callback, which disables the state check and trusts the hostname parameter. Malicious web pages can send a stateless request to port 53682 during authorization, planting attacker tokens and API hosts so later transfers reach the attacker.

CVSS Base Scores

version 3.1