Incorrect Permission Assignment for Critical Resource Affecting tigervnc package, versions <1.15.0+dfsg-2.1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.25% (17th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-TIGERVNC-15805877
  • published29 Mar 2026
  • disclosed26 Mar 2026

Introduced: 26 Mar 2026

CVE-2026-34352  (opens in a new tab)
CWE-732  (opens in a new tab)

How to fix?

Upgrade Debian:unstable tigervnc to version 1.15.0+dfsg-2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tigervnc package and not the tigervnc package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

In TigerVNC before 1.16.2, Image.cxx in x0vncserver allows other users to observe or manipulate the screen contents, or cause an application crash, because of incorrect permissions.

CVSS Base Scores

version 3.1