Double Free Affecting tigervnc package, versions <1.7.0+dfsg-7


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.82% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-TIGERVNC-304252
  • published1 Apr 2017
  • disclosed1 Apr 2017

Introduced: 1 Apr 2017

CVE-2017-7393  (opens in a new tab)
CWE-415  (opens in a new tab)

How to fix?

Upgrade Debian:unstable tigervnc to version 1.7.0+dfsg-7 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tigervnc package and not the tigervnc package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

In TigerVNC 1.7.1 (VNCSConnectionST.cxx VNCSConnectionST::fence), an authenticated client can cause a double free, leading to denial of service or potentially code execution.