Out-of-Bounds Affecting tigervnc package, versions <1.7.0+dfsg-3


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.25% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-TIGERVNC-304258
  • published28 Feb 2017
  • disclosed28 Feb 2017

Introduced: 28 Feb 2017

CVE-2017-5581  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:unstable tigervnc to version 1.7.0+dfsg-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tigervnc package and not the tigervnc package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Buffer overflow in the ModifiablePixelBuffer::fillRect function in TigerVNC before 1.7.1 allows remote servers to execute arbitrary code via an RRE message with subrectangle outside framebuffer boundaries.