Code Affecting tqdm package, versions <4.11.2-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.44% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-TQDM-415859
  • published19 Jan 2017
  • disclosed19 Jan 2017

Introduced: 19 Jan 2017

CVE-2016-10075  (opens in a new tab)
CWE-17  (opens in a new tab)

How to fix?

Upgrade Debian:unstable tqdm to version 4.11.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tqdm package and not the tqdm package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

The tqdm._version module in tqdm versions 4.4.1 and 4.10 allows local users to execute arbitrary code via a crafted repo with a malicious git log in the current working directory.