Out-of-bounds Write Affecting webkit2gtk package, versions <2.36.6-1


0.0
high

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
SUSE
8.3 high
Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIANUNSTABLE-WEBKIT2GTK-2976426
  • published 8 Aug 2022
  • disclosed 23 Sep 2022

How to fix?

Upgrade Debian:unstable webkit2gtk to version 2.36.6-1 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream webkit2gtk package. See How to fix? for Debian:unstable relevant versions.

An out-of-bounds write issue was addressed with improved input validation. This issue is fixed in iOS 15.6 and iPadOS 15.6, watchOS 8.7, tvOS 15.6, macOS Monterey 12.5, Safari 15.6. Processing maliciously crafted web content may lead to arbitrary code execution.