CVE-2026-15442 Affecting wolfssl package, versions <5.9.2-1.1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.21% (11th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-WOLFSSL-20186125
  • published28 Sept 2026
  • disclosed27 Sept 2026

Introduced: 27 Sep 2026

CVE-2026-15442  (opens in a new tab)

How to fix?

Upgrade Debian:unstable wolfssl to version 5.9.2-1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream wolfssl package and not the wolfssl package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

In all builds that make use of (D)TLS, including default builds, there is a series of conditional states during the TLS shutdown which could lead to a heap-use-after free. If an application ended up getting a partial wolfSSL_read() which is sometimes caused by a small user buffer passed in, then called wolfSSL_shutdown for a bidirectional close and attempted to wolfSSL_read() again while the peer continues trying to send data during the shutdown it would lead to a state where a potential heap-use-after free happened.

CVSS Base Scores

version 3.1