Arbitrary Command Injection Affecting xdg-utils package, versions <1.1.0~rc1+git20111210-7.3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.26% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIANUNSTABLE-XDGUTILS-309976
  • published21 Jan 2015
  • disclosed21 Jan 2015

Introduced: 21 Jan 2015

CVE-2014-9622  (opens in a new tab)
CWE-77  (opens in a new tab)

How to fix?

Upgrade Debian:unstable xdg-utils to version 1.1.0~rc1+git20111210-7.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream xdg-utils package and not the xdg-utils package as distributed by Debian. See How to fix? for Debian:unstable relevant fixed versions and status.

Eval injection vulnerability in xdg-utils 1.1.0 RC1, when no supported desktop environment is identified, allows context-dependent attackers to execute arbitrary code via the URL argument to xdg-open.

CVSS Base Scores

version 3.1