Arbitrary Script Injection Affecting angularjs.core package, versions [,1.2.30)


0.0
medium
  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-ANGULARJSCORE-1579450

  • published

    23 Jan 2017

  • disclosed

    26 May 2016

  • credit

    Raphaël Jamet

How to fix?

Upgrade AngularJS.Core to version 1.2.30 or higher.

Overview

AngularJS.Core is an AngularJS.* package for other Angular modules within .NET.

Affected versions of this package are vulnerable to Arbitrary Script Injection. Attributes were not protected via $sce, which prevents interpolated values that fail the RESOURCE_URL context tests from being used in interpolation. For example if the application is running at https://docs.angularjs.org then the following will fail:

<link href="{{ 'http://mydomain.org/unsafe.css' }}" rel="stylesheet">

By default, RESOURCE_URL safe URLs are only allowed from the same domain and protocol as the application document.