Information Exposure Affecting azure.storage.queues package, versions [,12.11.0)


0.0
medium
  • Attack Complexity

    High

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-AZURESTORAGEQUEUES-2949176

  • published

    13 Jul 2022

  • disclosed

    13 Jul 2022

  • credit

    Sophie Schmieg

How to fix?

Upgrade Azure.Storage.Queues to version 12.11.0 or higher.

Overview

Azure.Storage.Queues is an Azure Storage Queues client library for .NET

Affected versions of this package are vulnerable to Information Exposure. Attackers can expose the contents of a file or blob when client-side encryption is in use.

NOTE: The vendor advises that client-side encryption is a very uncommon use case.

References