Remote Code Execution (RCE) Affecting cefsharp.wpf package, versions [, 86.0.241)


0.0
high
  • Exploit Maturity

    Mature

  • Attack Complexity

    Low

  • User Interaction

    Required

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-CEFSHARPWPF-1048085

  • published

    4 Nov 2020

  • disclosed

    2 Nov 2020

  • credit

    Bill Parks

How to fix?

Upgrade CefSharp.Wpf to version 86.0.241 or higher.

Overview

CefSharp.Wpf is a the CefSharp Chromium-based browser component (WPF control).

Affected versions of this package are vulnerable to Remote Code Execution (RCE). A vulnerability exists in V8 implementation of Google Chrome that allows a remote attacker to potentially exploit heap corruption via a crafted HTML page. There is currently little to no public information on the issue other than it has been flagged as High severity.