Arbitrary Code Execution Affecting compositec1.core package, versions [,6.1.1)


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-COMPOSITEC1CORE-1921100

  • published

    16 Nov 2021

  • disclosed

    16 Nov 2021

  • credit

    Le Ngoc Anh - Sun Cyber Security Research Team

How to fix?

Upgrade CompositeC1.Core to version 6.1.1 or higher.

Overview

CompositeC1.Core is a .NET based Web Content Management System.

Affected versions of this package are vulnerable to Arbitrary Code Execution. Within Composite.dll there is a lack of proper validation of user-supplied data, which can result in the deserialization of untrusted data. An attacker can leverage this vulnerability to execute code in the context of the service account.

References