Arbitrary Code Execution Affecting halibut package, versions [,4.4.7)


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-HALIBUT-1658294

  • published

    24 Sep 2021

  • disclosed

    23 Sep 2021

  • credit

    Unknown

How to fix?

Upgrade Halibut to version 4.4.7 or higher.

Overview

Halibut is a secure, RPC-based communication framework.

Affected versions of this package are vulnerable to Arbitrary Code Execution. A deserialisation vulnerability allows remote code execution on systems that already trust each other based on certificate verification.

References