Access Control Bypass Affecting kentico.libraries Open this link in a new tab package, versions [9.0.0,9.0.51) [10.0.0,10.0.48)


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-KENTICOLIBRARIES-174370

  • published

    18 Apr 2019

  • disclosed

    11 Dec 2017

  • credit

    Unknown

How to fix?

Upgrade Kentico.Libraries to version 9.0.51, 10.0.48 or higher.

Overview

Kentico.Libraries is a runtime assemblies for libraries and applications that use Kentico API.

Affected versions of this package are vulnerable to Access Control Bypass. An attacker can grant himself Global Administrator access when because he is able to access the installation wizard and initiate the installation of a new starter site.

References