SQL Injection Affecting kentico.libraries.web.ui package, versions [10.0.0,10.0.50) [11.0.0,11.0.3)


0.0
high
  • Attack Complexity

    Low

  • Privileges Required

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-KENTICOLIBRARIESWEBUI-174400

  • published

    18 Apr 2019

  • disclosed

    19 Mar 2018

  • credit

    Unknown

How to fix?

Upgrade Kentico.Libraries.Web.UI to version 10.0.50, 11.0.3 or higher.

Overview

Kentico.Libraries.Web.UI is a runtime assemblies for Web Forms applications that use Kentico API.

Affected versions of this package are vulnerable to SQL Injection due to improper handling of user controlled input when SQL queries are being built.