Insecure Randomness Affecting magenic.maqs Open this link in a new tab package, versions [,6.3.0)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-MAGENICMAQS-1278131

  • published

    18 Jun 2021

  • disclosed

    30 Apr 2021

  • credit

    Unknown

Introduced: 30 Apr 2021

CWE-330 Open this link in a new tab

How to fix?

Upgrade Magenic.Maqs to version 6.3.0 or higher.

Overview

Affected versions of this package are vulnerable to Insecure Randomness as it creates temporary files with predictable names, which allows local users to overwrite arbitrary files via a symlink attack.

References