Information Exposure Affecting microsoft.aspnetcore.app package, versions [5.0.0,5.0.9) [3.1.0,3.1.18) [2.1.0,2.1.29)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-MICROSOFTASPNETCOREAPP-1540882

  • published

    13 Aug 2021

  • disclosed

    13 Aug 2021

  • credit

    Unknown

How to fix?

Upgrade Microsoft.AspNetCore.App to version 5.0.9, 3.1.18, 2.1.29 or higher.

Overview

Microsoft.AspNetCore.App is a package that provides a default set of APIs for building an ASP.NET Core application.

Affected versions of this package are vulnerable to Information Exposure via an unknown attack vector.