Remote Code Execution (RCE) Affecting microsoft.aspnetcore.app package, versions [,2.1.20) [3.0.0,3.1.6)


0.0
critical

Snyk CVSS

    Exploit Maturity Mature
    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
RHEL
8.8 high
Expand this section
NVD
7.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DOTNET-MICROSOFTASPNETCOREAPP-584430
  • published 15 Jul 2020
  • disclosed 14 Jul 2020
  • credit Oleksandr Mirosh from Micro Focus Fortify

How to fix?

Upgrade Microsoft.AspNetCore.App to version 2.1.20, 3.1.6 or higher.

Overview

Microsoft.AspNetCore.App is a package that provides a default set of APIs for building an ASP.NET Core application.

Affected versions of this package are vulnerable to Remote Code Execution (RCE). The software fails to check the source markup of XML file input. An attacker who successfully exploited the vulnerability could run arbitrary code in the context of the process responsible for deserialization of the XML content. To exploit this vulnerability, an attacker could upload a specially crafted document to a server utilizing an affected product to process content.