Authentication Bypass Affecting microsoft.aspnetcore.identity Open this link in a new tab package, versions [,1.0.6) [1.1.0,1.1.6) [2.0.0,2.0.4) [2.1.0,2.1.2)


0.0
high
  • Attack Complexity

    Low

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-MICROSOFTASPNETCOREIDENTITY-60260

  • published

    26 Jul 2018

  • disclosed

    11 Jul 2018

  • credit

    Unknown

How to fix?

Upgrade microsoft.aspnetcore.identity to versions 1.0.6, 1.1.6, 2.0.4, 2.1.2 or higher.

Overview

microsoft.aspnetcore.identity is the membership system for building ASP.NET Core web applications, including membership, login, and user data.

Affected versions of the package are vulnerable to Authentication Bypass. The number of incorrect login attempts is not validated, as a result a malicious user could try an infinite number of authentication attempts.

References