Privilege Escalation Affecting microsoft.aspnetcore.mvc package, versions [,1.0.1)


0.0
high
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-MICROSOFTASPNETCOREMVC-60113

  • published

    1 Feb 2017

  • disclosed

    1 Feb 2017

  • credit

    Unknown

How to fix?

Upgrade Microsoft.AspNetCore.Mvc to version 1.0.1 or higher.

Overview

Microsoft.AspNetCore.Mvc is a web framework that gives you a powerful, patterns-based way to build dynamic websites and web APIs.

Affected versions of this package are vulnerable to Privilege Escalation. View Components could receive incorrect information, including details of the current authenticated user. If a View Component depends on the vulnerable code and makes decisions based on the current user, then the View Component could make incorrect decisions that result in elevation of privilege.