Remote Code Execution (RCE) Affecting microsoft.aspnetcore.spaservices package, versions [2.1.0,2.1.2) [2.2.0,2.2.1)


0.0
critical
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Scope

    Changed

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-MICROSOFTASPNETCORESPASERVICES-466519

  • published

    11 Sep 2019

  • disclosed

    10 Sep 2019

  • credit

    Ian Routledge (@ediblecode)

How to fix?

Upgrade Microsoft.AspNetCore.SpaServices to version 2.1.2, 2.2.1 or higher.

Overview

Microsoft.AspNetCore.SpaServices is a package Helpers for building single-page applications on ASP.NET MVC Core.

Affected versions of this package are vulnerable to Remote Code Execution (RCE). When a WebApp is created using vulnerable project templates, fails to properly sanitize requests. An attacker who successfully exploited this vulnerability could perform content injection attacks and run script in the security context of the logged-on user.