Privilege Escalation Affecting microsoft.identitymodel.tokens package, versions [,5.1.1)


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-DOTNET-MICROSOFTIDENTITYMODELTOKENS-60016

  • published

    10 Jan 2017

  • disclosed

    10 Jan 2017

  • credit

    Unknown

How to fix?

Upgrade Microsoft.IdentityModel.Tokens to version 5.1.1 or higher.

Overview

Microsoft.IdentityModel.Tokens Includes types that provide support for cryptographic operations.

Affected versions of this package are vulnerable to Privilege Escalation. A security vulnerability in the public version of Microsoft.IdentityModel.Tokens 5.1.0 where tokens signed with symmetric keys could be vulnerable to tampering.